No output on USB serial


#1

Hi,

Just got my board and was trying to bring it up. It took me a while to find instructions on bringing it up. I used the “mindb_dd.tar.gz” image and put that image on an SD Card. I powered it up and windows registered a new usb com port. I attached to this com port but didn’t see any output. Should I use a different image or am I doing something wrong? It does look like it is booting up as I see a serial port enumerating and showing up as a serial port on windows.

Thanks
Kim


#2

Hey, sorry to reply to my own post but I figured some things out. After reading jlsilicon’s post about BASICS - GPIO Pins and Ports - HOWTO: I was able to get my lichee pi zero booting. I followed the instructions and hooked up a USB to Serial cable and I could see it booting. I knew it was booting. Now there is a gotcha to be aware of. The card that is sent along with the lichee pi board is not correct when it comes to U0T and U0R. On the card TX and RX are swapped. Look at the silk screening on the board itself. The silk screening is correct the card is swapped. That had me scratching my head for a bit.

Thanks for the cool little board
Kim


#3

Oh, I’m sorry I make the mistake, the silk screening is correct.


#4

I got my 2 Lichee Pi’s in the mail the other day, I have successfully got one of the boards up and running, as well as all of the breadboard pins soldered. I’ll have to play around with it a bit more, but thanks to jlsilicon’s tutorial post I can tell it is working. I’m very pleased with my purchase so far!

Thanks Zepan!


【Tutorial】- LicheePiZero - BASICS - GPIO Pins and Ports - Howto
Having challenges getting started
#5

I don’t know if this has been mentioned somewhere else, but you can add:

T1:2345:respawn:/sbin/getty -L ttyGS0 115200 vt100

to your /etc/inittab and then you can log in over the microusb serial port, and not need to attach a uart cable each time.


#6

The Debian images I got from licheepizero.us use systemd instead of init, so /etc/inittab is completely ignored. Here’s what I had to do to get it up and running:

  • Log in via usb/tty adapter (sudo cu -s 115200 -l /dev/cu.YOURPORT on my mac), root / toortoor
  • Add ttyGS0 to the end of /etc/securetty to enable root login, otherwise it will say Login incorrect as soon as you enter root
  • Make a systemd getty entry: ln -s /lib/systemd/system/serial-getty\@.service /etc/systemd/system/getty.target.wants/getty\@ttyGS0.service
  • Start the systemd service: systemctl start getty\@ttyGS0.service
  • Restart and it should start with the system

【Tutorial】- LicheePiZero - BASICS - GPIO Pins and Ports - Howto
#7

Sorry, I do not see it appear in my COM Ports - connecting via USB.
I can still login via Serial T1 R1 port though.