Ethernet looks broken in Linux 4.13


Spent all day trying compile Linux kernel 4.13 with ethernet support, without success.
Linux sources cloned today from linux-sunxi git.
Anybody tried ethernet on that kernel ??
Have working ethernet on 4.12-rc1 (from here provided git)…


Did you try the 4.13.y branch from Lichee-Pi/linux on github?


Not yet, will give a try.
Do you know difference in
Lichee-Pi/linux 4.13.exp and 4.13.y ?


Lichee-Pi/linux-4.14.y work, but it include reversion of commits about Ethernet.


Could you help me? I’m struggling with that topic, too.
Which kernel is the newest and support Ethernet?


I’m using Kernel 4.13 from Lichee , it include reverts to solve Ethernet problems. Changes was done between 4.10 and 4.13 (may be even shorter - 4.12 - 4.13 ) .
You can try use 4.11 or 4.12 to get Ethernet support.

I sow many discussions about that in Linux group, but didn’t catch is it finally solved or not.


Thank you I will give it a try.

They removed the dwmac sun8i ethernet driver, because it is “unstable”.
I never encountered a problem with the driver on my V3s.
You can read the linux mainling effort from Sunxi here: