platformio!


#1

I just noticed that platformio now supports the Sipeed boards thanks to the Sipeed team. Very nice! I love working with platformio.

The only problem I had was that when trying to upload the firmware with ‘platformio run --target upload’ (compiling works good). Platformio says that I need to install enum34 via pip. However, kflash uses python3, which in my case is linked through to python3.5, and enum34 is not supported in python3.5. However, if I use kflash without platformio it works fine:
~/.platformio/packages/tool-kflash-kendryte210/kflash.py .pioenvs/sipeed-maix-go/firmware.bin
So, I do not know what causes the enum34 problem.

Thank you!


#2

We just updated kflash to version 0.8.2 and it no longer needs any dependencies. You can try to update it.


#3

Perfect!!


#4

Yesterday I installed VSCode on linux. Again, compilation worked good but uploading gave a strange error. It auto-detected the correct device (in mij case /dev/ttyACM0) but then gave an error that it could not find the correct COM port and that I had to manually set --port. If I specify ‘upload_port’ in platformio.ini it did not correct the error. Of course on linux there are no COM ports, so it seems some windows-specific code is active. Is that in VSCode, in platormio or in kflash?

And there was a spelling error: “vaild” should probably be “valid” (occurs 4 times).

Edit:
One problem solved: I use the CMSIS-DAP firmware. In ".platformio/platforms/kendryte210/boards/sipeed-maix-go.json" the "burn_tool" is specified as "goE" while for CMSIS-DAP it has to be "goD".

But I now get another error …


#5

You can change some default configuration options in platformio.ini like this,

[env:sipeed-maix-go]
platform = kendryte210
framework = arduino          (可选择 kendryte210-standalone-sdk)
board = sipeed-maix-go
monitor_speed = 115200       (串口监视器的波特率)
upload_port = COM3          (可选,指定下载端口,不配置则自动选择)
board_upload.burn_tool = goD  (可选,Maix Go编程器固件选择,不配置则默认为open-ec)
board_upload.speed = 3000000  (可选,固件下载波特率,不配置则默认为2M.)