Maix Go not detected


#1

So I bought this Sipeed Maix Go recently, and I’m having a trouble connecting it to my laptop. It may seem like a simple problem, but I haven’t been able to solve it for weeks.

My laptop (Windows 8) just simply doesn’t detect my Maix Go when I plug it using the USB type-C cable. Nothing appears in the device manager, not even an unrecognized USB or such. I already installed the SMT32 driver for my laptop, and tried it also with different cables and on different laptops, including one with MacOS and Windows 7, but other than the charge LED blinking red on Maix Go, nothing else happens. However, re-burning firmware via the ST Link seems to be fine.

Did I miss something? Any leads?

Thank you


#2

At the risk of stating the obvious: you mention that only the charge LED is blinking, did you switch the Maix Go on (the little switch next to the charge LED)? There should be another solid red LED on the other side of the switch, and there should be a solid blue and a blinking blue LED.


#3

Thanks for the reply.

Yeah, it appears to be the problem. :triumph:

I was a little surprised since I tried turning it on before (but I haven’t done firmware things on that time, and not a single LED is flashing when I plug it to laptop with the maix go switched off) and it didn’t worked.
But anyway, everything works normally now.

Thank you.